[libvirt] cannot migrate vm back to original machine

Elaine Cheong elcheong at cisco.com
Thu Jun 26 23:32:05 UTC 2008

I am running Fedora 8 with Xen 3.1.2 and libvirt 0.4.3 on two machines  
(machine #1 and #2).  I am using virDomainMigrate() to migrate a VM  
from machine #2 (where it originally resides) to machine #1.  I am  
unable to migrate the VM back to machine #2 using virDomainMigrate(),  
even if I first migrate the VM from #2 to #1 by hand, using "xm  
migrate -l <vmname> <ipaddress1>".

When I make the call to virDomainMigrate(domain_to_migrate,  
connection_to_machine_2, VIR_MIGRATE_LIVE, NULL, NULL, 0), I get the  
following message:

libvir: Xen Daemon error : POST operation failed: xend_post: error  
from xen daemon: (xend.err "can't connect: Name or service not known")

I have tried running my program on both machine #2 (connecting to  
machine #1 with ssh, and machine #2 with local (NULL) or ssh), and on  
a separate 3rd machine (connecting to machine #1 and #2 with ssh), but  
I get the same error message in both cases.  I've tried connecting  
with both virConnectOpen() and virConnectOpenReadOnly().

I don't see any obvious error messages when running libvirtd -- 
verbose, other than the one above, which shows up on machine #1.   
There are no obvious error messages in libvirtd --verbose on machine #2.

I checked /var/log/xen/xend.log and xend-debug.log, but didn't see any  
error message there either.  My /etc/xen/xend-config.sxp is set with  
default loglevel of DEBUG.

Any clues as to why I cannot migrate the VM back to the original  
machine with libvirt?  I am able to migrate it back from #1 to #2 by  
hand using "xm migrate -l <vmname> <ipaddress2>".


More information about the libvir-list mailing list