[libvirt] Problem with fullyvirtualized guest direct kernel boot

Max Martynov mcsimm at gmail.com
Thu Nov 6 18:07:22 UTC 2008

>> > Kernel, initrd and root file system are extracted from working Fedora 9 disk
>> > image without any additional tinkering. Guest Fedora is clean and was
>> > installed from scratch. When I use this whole disk image with
>> > fullyvirtualized guest BIOS boot with, everything works fine. I also tried
>> > paravirtualized guest bootloader with another linux kernel and it also works
>> > fine. Xen version is 3.2.1-rc1-pre. Host OS is Ubuntu Hardy.
>> That Xen is too probably old - you need 3.3.x or newer. The Xen 3.2 in
>> Fedora has a backport of this functionality, and I doubt the Ubuntu xen
>> has copied that.
> Thanks, I will try to do that. However, the sample for
> fullyvirtualized guest direct kernel boot uses Fedora.

I have tried to perform the same experiment with Xen 3.3.0, and the
same error occured. Moreover, I have tried to use the kernel from my
host Ubuntu (vmlinuz-2.6.24-21-server) and error was the same.
However, using vmlinuz-2.6.24-21-xen kernel still worked fine, but in
paravirtualized mode I suppose.

All the kernels and initrds I have tried to use were taken from /boot/
without any additional modifications. Is it correct usage for full
virtualization or some tuning should be performed? Or maybe Ubuntu as
a host doesn't support full virtualization for direct kernel boot at


More information about the libvir-list mailing list