[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt][solved] domain type "kvm" error

Cole Robinson wrote:
I use "ubuntu hardy" but I dont think the problem is specific to the
distribution I use.

I installed KVM and libvirt as described here:

Following that method, created a domain, which dumps like this:
  <domain type='qemu' id='1'>

Specifically what tool did you use to install the VM? That tutorial lists
several different methods.

$ sudo virt-install --connect qemu:///system -n xp1 \
    -r 512 -f xp1.qcow2 -s 12 -c xp.iso --vnc \
    --noautoconsole --os-type windows --os-variant winxp

Launching the guest is OK, but it is as slow as if I directly launched
  $ qemu [options]
I tried to launch:
  $ kvm [options]
and it is much faster
My conclusion is that method on the Ubuntu documentation launches a
qemu without the use of kvm.
I modified that XML dump, changing "qemu" with "kvm":
  <domain type='kvm' id='1'>
You can't just change the domain type, you also have to change
the emulator tag. My guess is, this new 'kvm' command is still
using the plain qemu emulator and not '/usr/bin/kvm'

Great! I changed it and it runs!
I really did not see it.

Hope that helps,

It did!

Huile Essentielle de Camphre http://www.huile-camphre.fr
Infogerance http://www.infogerance.us
(Serveurs, Postes de travail, Développement logiciel)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]