[libvirt] Cannot start domain w/xenner emulator

Gerry Reno greno at verizon.net
Wed Dec 16 16:03:22 UTC 2009

Gerry Reno wrote:
> Gerry Reno wrote:
>>> And again if I run this command from the command line it works and 
>>> xenstored does not crash.
>> I spoke too soon. I just checked again and xenstored crashed but the 
>> guest domU is running from the command line.
>> -Gerry
> Here is what the original pygrub.cfg looks like for this domU image:
> bootloader = "/usr/bin/pygrub"
> memory = 256
> name = "ubuntu.9-10.x86"
> vif = [ '' ]
> disk = ['file:/var/stacklet/ubuntu.9-10.x86.img,sda1,w']
> extra = "fastboot"
> I tried setting the target in the xml to "sda1" but it doesn't like 
> that and only accepts "sda".
> -Gerry
And I tried moving all this from Ubuntu 9.10 box over to F11 box 
w/xenner and there libvirt generates a bad xenner command line.  Here is 
the F11 domain log:

LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin /usr/bin/xenner -S -M pc -m 
2048 -smp 4 -name Ubuntu-domU-x86-1 -uuid 
5ab6d1df-14fc-2eee-1fa4-b72fb7ba9321 -domid 4 -nographic -monitor pty 
-pidfile /var/run/libvirt/qemu//Ubuntu-domU-x86-1.pid -boot c -kernel 
-append xencons=xvc console=tty1 console=xvc0 -drive 
file=/var/lib/libvirt/images/ubuntu.9-10.x86.img,if=xen,index=0 -net 
nic,macaddr=54:52:07:2d:e1:81,vlan=0 -net tap,fd=23,vlan=0 -serial pty 
-parallel none -usb
[xenner,1] qemu_monitor_config: pty
char device redirected to /dev/pts/6
unknown option (or missing arg): -pidfile
QEMU PC emulator version 0.9.1
 * No, it isn't.  This just makes libvirt qemu version detection happy,
 * so you can manage xenner guests using libvirts qemu driver.

xenner v0.46 -- run xen kernels in kvm

usage: xenner [options]
options (qemu compatible):
   -help                    print this text
   -S                       start with vcpus stopped
   -kernel     <kernel>     xenified kernel image
   -initrd     <ramdisk>    ramdisk
   -append     <append>     kernel command line
   -name       <string>     set domain name
   -monitor    pty          monitor on pseudo tty
   -m          <memory>     vm memory in megabytes
   -smp        <cpus>       set number of vcpus
   -hd[abcd]   <file>       disk image
   -cdrom      <file>       cdrom image
   -drive      <config>     qemu style disk setup
   -net        <config>     qemu style network setup
   -serial     <config>     qemu style serial line (aka console) setup
   -vnc        <display>    vnc display (needs qemu-dm from xen-tools)
   -k          <kbd>        vnc clients keyboard map

options (xenner only):
   -domid      <id>         set domain id
   -uuid       <uuid>       set domain uuid
   -network    <mac>,<br>   xenner style network setup
   -debug      <nr>         set debug level
   -logfile    <file>       set logfile
   -bootloader <app>        set bootloader
   -cap-on     <name>       enable kvm features
   -cap-off    <name>       disable kvm features
   -nostderr                send messages to logfile only
   -dumpcore                don't catch fatal signals (sigsegv, sigbus)
   -libvirt-caps            print libvirt capability xml snippet

pick device model:
   -qemu-path  <file>       path to qemu binary
   -qemu-dm                 qemu is xensource qemu-dm
   -qemu-upstream           qemu is upstream+patches
               => http://kraxel.fedorapeople.org/patches/

Some more qemu-ish options are accepted but ignored,
so we don't error out when started by libvirt.

When started without kernel specified xenner tries to
get one using the bootloader (pygrub by default).

(c) 2007,08 Gerd Hoffmann <kraxel at redhat.com>

Arrrgh...    How to get this working?


More information about the libvir-list mailing list