[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Cannot get network to work with LXC

Quoting James Yu (cyu021 gmail com):
> Hi all,
> I tried to use the first xml config in http://libvirt.org/drvlxc.html to

Which version of libvirt were you using?  Was it the one which came with
your distro, and, if so, which distro?  You might try installing the
version from
	git clone git://libvirt.org/libvirt.git

> setup my first light weight container.
> However, I was unable to get the container's network to work.
> When I tried to give the interface an IP, I got the following error message:
> sh-4.0# /sbin/ifconfig veth1
> SIOCSIFADDR: Permission denied
> SIOCSIFNETMASK: Permission denied
> SIOCGIFADDR: Cannot assign requested address
> SIOCSIFBROADCAST: Permission denied
> SIOCSIFFLAGS: Permission denied
> sh-4.0#
> Any advise ?
> This is a UTF-8 formatted mail
> -----------------------------------------------
> James C.-C.Yu

> --
> Libvir-list mailing list
> Libvir-list redhat com
> https://www.redhat.com/mailman/listinfo/libvir-list

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]