[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] Fedora Virtualization ... some comments and a request for help

First some background ...

For the last two to three weeks, I have been working with Fedora (Linux) 
virtualization ... specifically qemu/kvm.  I have been a long time user of 
VMware and and am hoping to migrate to Fedora Virtualization ("to change my 
problem set").

I have successfully installed and run CentOS 5.3, Fedora 9, and Fedora 11 in 
both i386 and x86_64 flavors.  I have also installed and run Win2k PRO.  All of 
this worked just fine.  Mostly I used virt-manager and only resorted to 
command-line software when there was no alternative.

While I initially had some problems with the way sVirt was doing things, I 
installed the preview set of packages (libvirt 0.6.5, etc) and it is mostly 
"good enough" [I did find one "bug" which has been bugzillaed].

Now my problem!  

I am not sure if I am trying to do something which currently cannot be done, 
if I have found one or more bugs, or if I just need some help to point me in 
the right direction.

I am trying to "migrate" some VMware guests over to qemu-kvm.  I have tried 
Win2k guests, F9 guests, and F11 guests.  Because I sense that the HW version 
of the disk images may be a problem, I made sure that all of the disk images 
were version 3 or 4.  Using vmware-vdiskmanager, I converted any "split disks" 
into a single file.

I tried using the vmdk files from wmare.  I tried converting the files (using 
qemu-img) to both qcow2 and raw format.  I tried using partimage-ng to save 
(on vmware) and then restore (on qemu-kvm) the disk images.

Nothing works!

For Win2k, the guest system starts booting and then I get a host system kernel 
oops.  I also tried Win2k with qemu only (no kvm) ... the system started 
booting and then rebooted ... endlessly.

For Fedora guests with LVM, grub brings in the kernel but then immediately 
fails because it cannot find the logical volumes.  For Fedora guests with just 
/boot, swap, and / partitions, they fail after grub loads the kernel because 
(IIRC) "setuproot" fails ... it cannot find the root partition.

I examined all of the virtual disk images that failed with guestfish and they 
all looked OK.  I also attached some of these virtual disks and booted up 
under the rescue mode of the distribution DVD and the disks looked OK there 

BUT nothing worked!

Then I ran some tests with guests created under qemu-kvm.  I created a small 
guest by installing F11 on a SCSI drive (after doing a dance to swap things 
around).  This scsi install installed and ran fine.

I then took the disk image file and attached it to another guest as an IDE 
drive!  This booted up and ran fine.

Finally, I used partimage-ng to save the disk image originally created as SCSI 
and restored it to a different ide attached disk image ... this also booted up 
and ran fine.

There is documentation out there (some, not a lot) which says that I should be 
able to "migrate" guests from VMware to qemu-kvm.  For example:
[I tried the above procedure, it did not work either]

What am I doing wrong???

Any hints (let alone outright explanations) will be appreciated.

BTW, there are statements that only vmdk version 3 and 4 formats ware 
supported.  If that is true, why are there error messages issued when a vmdk 
file is processed which is not version 3 or 4?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]