[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 9/9] Rename 'direction' to 'type' in remote_message_header

On Tue, Jul 14, 2009 at 11:21:11AM +0100, Daniel P. Berrange wrote:
> The 'remote_message_header' struct has a mis-leadingly named
> field 'direction'. It is really a reflection of the type of
> message, and some types can be sent in either direction. Thus
> the field is more accurately named 'type'. No function change.
> * qemud/remote_protocol.x: Rename 'direction' to 'type' in
>   'remote_message_header. Write better docs describing the
>   message header field semantics & usage
> * qemud/remote_protocol.c, qemud/remote_protocol.h: Regenerate
> * qemud/remote.c, qemud/dispatch.c, src/remote_internal.c
>   Update to reflect rename of 'direction' to 'type'

  With extra documentation, cool, ACK !


Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]