[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] VMware support and Server 2.0.1

2009/7/27 Timo Makinen <tmakinen ee oulu fi>:
> I tested libvirt with VMware Server 2.0.1 (not ESX). Server starts
> http on port 8333 as default and libvirt api did not have any option
> to give port number when connecting.
> Maybe connecting should be changed to support uris like:
> esx://host:123/

I'll add that.

> Next i tried to hardcode port into libvirt and got following error:
> error: internal error Expecting server major/minor version '3.5' or '4.0' but found '2.0.1'

But the VI API version check worked unchanged? So VMware GSX 2.0 (GSX
is the internal name for the Server product line) supports at least VI
API version 2.5.

I'll extend the version checks to allow ESX/ESXi 3.5/4.0 and GSX 2.0
with VI API 2.5/4.0.

> I patched libvirt again and finally got connected. Well at least list
> command gave out list of vms. With dumpxml i got following error:
> virsh # dumpxml vm02
> error: internal error Missing essential config entry ''

Strange, the error message states that the driver tries to lookup an
empty key in the VMX file. I'll have to see where that comes from in
the driver.

Could you do some basic testing beside listing and dumpxml, as I have
currently no VMware GSX installation at hand? Just test if the
following commands work as expected in virsh:

- start
- shutdown
- reboot
- suspend
- resume
- nodeinfo
- dominfo


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]