[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Drop the leading lib from libvirt. Based on testing by thomas@scripty.at this is a better way to load the libarary

On Thursday 30 July 2009 16:24:02 Daniel Veillard wrote:
> On Thu, Jul 30, 2009 at 10:13:49AM -0400, Bryan Kearney wrote:
> > ---
> >  src/main/java/org/libvirt/jna/Libvirt.java |    2 +-
> >  1 files changed, 1 insertions(+), 1 deletions(-)
>   Per previous discussion, ACK !
> It's better to not try to load a library we know doesn't exist (or if
> it was it might not be ours...)

Now tried to use LD_LIBRARY_PATH, that works too (without this patch). But I 
really do not understand why setting that env var is necessary 
when /usr/local/lib is in my ld.so.conf and considering the following output, 
which is looking good, AFAIK:

$ ldconfig -p | grep libvirt                                                
        libvirt_jni.so.0 (libc6,x86-64) => /usr/local/lib/libvirt_jni.so.0
        libvirt_jni.so (libc6,x86-64) => /usr/local/lib/libvirt_jni.so
        libvirt_jni.so (libc6,x86-64) => /usr/lib/libvirt_jni.so
        libvirt.so.0 (libc6,x86-64) => /usr/local/lib/libvirt.so.0
        libvirt.so (libc6,x86-64) => /usr/local/lib/libvirt.so

Ah, and tried JNA 3.0.9 too, no difference at all. 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]