[libvirt] USB pass-through only works after many disconnects at the beginning

Daniel P. Berrange berrange at redhat.com
Tue May 5 09:49:34 UTC 2009

On Sun, May 03, 2009 at 09:21:20PM +0200, Felix Schwarz wrote:
> Hi,
> I want to pass through a USB device to a KVM guest (Windows 2000). My host 
> OS
> is a standard Fedora 10, 64 bit. However, the device is only passed to the
> guest when I use qemu monitor directly and only after several tries...
> The device has no Linux drivers ('AVM GmbH ISDN-Controller FRITZ!Card v2.0')
> so I think I don't have to tell the kernel not to use it.
> I have KVM 74 and tried initially with libvirt 0.5.1 so from what I read 
> this
> should be ok.
> At first I added this to my domain xml via virsh:
> <hostdev mode='subsystem' type='usb'>
>    <source>
>      <vendor id='0x....'/>
>      <product id='0x....'/>
>    </source>
> </hostdev>
> However, the device did not turn up in the guest.

That should be what you need from a libvirt POV, so I'm afraid
you're probably hitting problems at the QEMU level instead.

> So how can I use USB pass through? Could this be Windows-related? Judging 
> from
> all the other threads (like [1]) it should be really easy to use.

I think best bet is to try updating to a newer KVM build - you ought
to be able to pull in the 'qemu-system-x86' RPM from Fedora 11 into
a F10 host without too many deps. That would let you see if newer
KVM userspace fixed it (no need to update kernel - USB passthrough
is purely a userspace issue)

|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|

More information about the libvir-list mailing list