[libvirt] [PATCH 15/30] xen: Remove virConnectPtr from xenUnifiedError

Matthias Bolte matthias.bolte at googlemail.com
Tue Apr 6 00:20:52 UTC 2010


2010/4/5 Eric Blake <eblake at redhat.com>:
> On 04/04/2010 11:36 AM, Matthias Bolte wrote:
>> ---
>>  src/xen/xen_driver.c |   62 +++++++++++++++++++++++++-------------------------
>>  1 files changed, 31 insertions(+), 31 deletions(-)
>>
>> diff --git a/src/xen/xen_driver.c b/src/xen/xen_driver.c
>> index a5d58d0..fb2f7c7 100644
>> --- a/src/xen/xen_driver.c
>> +++ b/src/xen/xen_driver.c
>> @@ -72,9 +72,9 @@ static struct xenUnifiedDriver const * const drivers[XEN_UNIFIED_NR_DRIVERS] = {
>>
>>  static int inside_daemon;
>>
>> -#define xenUnifiedError(conn, code, ...)                                   \
>> -        virReportErrorHelper(conn, VIR_FROM_XEN, code, __FILE__,           \
>> -                               __FUNCTION__, __LINE__, __VA_ARGS__)
>> +#define xenUnifiedError(code, ...)                                         \
>> +        virReportErrorHelper(NULL, VIR_FROM_XEN, code, __FILE__,           \
>> +                             __FUNCTION__, __LINE__, __VA_ARGS__)
>
> ACK, and the rest of the patch is mechanical fallout.

Thanks, pushed.

>> @@ -296,8 +296,8 @@ xenUnifiedOpen (virConnectPtr conn, virConnectAuthPtr auth, int flags)
>>          return VIR_DRV_OPEN_ERROR;
>>      }
>>      if (virMutexInit(&priv->lock) < 0) {
>> -        xenUnifiedError (NULL, VIR_ERR_INTERNAL_ERROR,
>> -                         "%s", _("cannot initialise mutex"));
>> +        xenUnifiedError(VIR_ERR_INTERNAL_ERROR,
>> +                        "%s", _("cannot initialise mutex"));
>
> Independent question - is there any preference for American vs. British
> spellings, or are both acceptable?  My understanding is that the whole
> point of translations is to provide en_US and en_UK translations, at
> which point it becomes easier for the translators if they always start
> from a consistent spelling in the .pot file (in case the same message
> occurs more than once in the source).  Therefore, should this be
> "initialize"?
>

If you grep the code for initialize and initialise you'll find both in
code and comments. IMHO this should be unified to AE, because there is
already way more AE then BE in the codebase, but that's worth a
separate patch.

Matthias




More information about the libvir-list mailing list