[libvirt] Two issues regarding TFTP support in virtual networks...

Darryl L. Pierce dpierce at redhat.com
Tue Jan 12 21:22:39 UTC 2010

On Mon, Jan 11, 2010 at 04:48:54PM +0100, Paolo Bonzini wrote:
> >>(mcpierce at mcpierce-desktop:node-image)$ sudo virsh net-dumpxml testbr541
> >><network>
> >>   <name>testbr541</name>
> >>   <uuid>f389317f-8420-7516-df9d-756b7deb3d37</uuid>
> >>   <forward mode='nat'/>
> >>   <bridge name='testbr541' stp='on' delay='0' />
> >>   <ip address='' netmask=''>
> >>     <tftp root='/tmp/tmp.3B8opJfBXw/tftpboot/' />
> >>     <dhcp>
> >>       <range start='' end='' />
> >>     </dhcp>
> >>   </ip>
> >></network>
> >>
> >>When I start up the VM, I see it get an IP address within the range
> >>specified, but it never pxeboots the ISO image.
> >>
> >>To what directory should the root attribute be pointed?
> >
> >If someone has a moment, could you please take a look and help me with
> >this situation? I've tried several scenarios and nothing seems to work
> >for pointing libvirt to the directory I've created.
> You are not giving BOOTP info (you are missing the <bootp> tag,
> which goes inside <dhcp>).

Okay, here's the XML that's now being generated by my test script:

<forward mode='nat' />
<bridge name='testbr6253' stp='on' forwardDelay='0' />
<ip address='' netmask=''>
<tftp root='/tmp/tmp.dEf7FPCaKm/tftpboot' />
<bootp file='pxelinux.0' />
<range start='' end='' />

However, I still get the message "No filename or root path specified"
within the VM and it does not boot from the above directory.

Darryl L. Pierce, Sr. Software Engineer @ Red Hat, Inc.
Delivering value year after year.
Red Hat ranks #1 in value among software vendors.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://listman.redhat.com/archives/libvir-list/attachments/20100112/7380c695/attachment-0001.sig>

More information about the libvir-list mailing list