[libvirt] Two issues regarding TFTP support in virtual networks...

Darryl L. Pierce dpierce at redhat.com
Wed Jan 13 15:35:11 UTC 2010

On Wed, Jan 13, 2010 at 10:17:01AM +0100, Paolo Bonzini wrote:
> >>You are not giving BOOTP info (you are missing the<bootp>  tag,
> >>which goes inside<dhcp>).
> >
> >Okay, here's the XML that's now being generated by my test script:
> >
> ><network>
> ><name>testbr6253</name>
> ><forward mode='nat' />
> ><bridge name='testbr6253' stp='on' forwardDelay='0' />
> ><ip address='' netmask=''>
> ><tftp root='/tmp/tmp.dEf7FPCaKm/tftpboot' />
> ><bootp file='pxelinux.0' />
> ><dhcp>
> ><range start='' end='' />
> ></dhcp>
> ></ip>
> ></network>
> >
> >However, I still get the message "No filename or root path specified"
> >within the VM and it does not boot from the above directory.
> <bootp> must be within <dhcp> (think of elements within <ip> as
> services that run, such as TFTP or DHCP; <bootp> is just additional
> data that is passed via DHCP).

Ah, okay. That wasn't clear to me in the wiki page on the network XML.
I'll give that a shot then.


Okay, still the same error. Here's the new XML being generated:

<forward mode='nat' />
<bridge name='testbr31018' stp='on' forwardDelay='0' />
<ip address='' netmask=''>
<tftp root='/tmp/tmp.6LUTF06Gkm/tftpboot' />
<bootp file='pxelinux.0' />
<range start='' end='' />

Are there any relative pathing values that should be used by the tftp
and bootp tags? Should the tftp->root attribute point to the work
directory and then bootp->file refer to tftpboot/pxelinux.0?

Darryl L. Pierce, Sr. Software Engineer @ Red Hat, Inc.
Delivering value year after year.
Red Hat ranks #1 in value among software vendors.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://listman.redhat.com/archives/libvir-list/attachments/20100113/8dd2a92f/attachment-0001.sig>

More information about the libvir-list mailing list