[libvirt] Two issues regarding TFTP support in virtual networks...

Darryl L. Pierce dpierce at redhat.com
Wed Jan 13 16:48:05 UTC 2010

On Wed, Jan 13, 2010 at 05:03:59PM +0100, Paolo Bonzini wrote:
> ><network>
> ><name>testbr31018</name>
> ><forward mode='nat' />
> ><bridge name='testbr31018' stp='on' forwardDelay='0' />
> ><ip address='' netmask=''>
> ><tftp root='/tmp/tmp.6LUTF06Gkm/tftpboot' />
> ><dhcp>
> ><bootp file='pxelinux.0' />
> ><range start='' end='' />
> ></dhcp>
> ></ip>
> ></network>
> >
> >Are there any relative pathing values that should be used by the tftp
> >and bootp tags? Should the tftp->root attribute point to the work
> >directory and then bootp->file refer to tftpboot/pxelinux.0?
> No, the above seems fine (I should have pointed you to
> tests/networkxml2xmlin/netboot-network.xml before).  Can you post
> the generated dnsmasq command line?

Here is what's output by libvirtd:

11:36:57.608: debug : virRun:809 : /usr/sbin/dnsmasq --strict-order --bind-interfaces --pid-file=/var/run/libvirt/network/testbr6762.pid --conf-file=  --listen-address --except-interface lo --dhcp-range, --dhcp-lease-max=100 --enable-tftp --tftp-root /tmp/tmp.HRG19a7Udi --dhcp-boot tftpboot/pxelinux.0

Now, this command line matches, WRT the pxe booting elements, our
pre-0.7 libvirtd test script that worked just fine. And I do see in the
vm getting an address via dhcp. But i'm still getting the error
"No filename or root path specified."

> Also, have you tried using wireshark to see what's going on?

No, I haven't.

Darryl L. Pierce, Sr. Software Engineer @ Red Hat, Inc.
Delivering value year after year.
Red Hat ranks #1 in value among software vendors.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://listman.redhat.com/archives/libvir-list/attachments/20100113/b6174fee/attachment-0001.sig>

More information about the libvir-list mailing list