[libvirt] Problems with attach-device/detach-device using libvirt 0.7.6

Daniel P. Berrange berrange at redhat.com
Mon Mar 1 12:54:16 UTC 2010

On Fri, Feb 26, 2010 at 04:24:11PM +0100, Rolf Eike Beer wrote:
> Hi,
> first a short summary of what the situation is:
> I'm running qemu 0.12.2, libvirt 0.7.6 on a E5520 based machine with kernel 
> 2.6.33. I also tried as I was using that before and still had the old 
> kernel around, but kernel version doesn't matter AFAICT. The host is a gentoo 
> AMD64 installation, the client is SuSE 11.0 (both 32 and 64 bit tested).
> This system is our machine to run automated PCIe device tests on, so the idea 
> is to move PCIe devices from the host to different vms, run some testcases 
> there and then move them away again. This has worked before (I'm not 
> absolutely sure, but I would bet a bit of money that it was libvirt 0.7.5).
> So, what I'm going to do is simply
> virsh # attach-device suse11.0-AMD64 dev-pci-AD1-CL.xml
> Device attached successfully
> virsh # detach-device suse11.0-AMD64 dev-pci-AD1-CL.xml
> Device detached successfully
> This is just was I expect and what I now get with the two patches attached. 
> The original situation was somewhat different (i.e. broken):
> -first I got complains in the log stating:
> tried to create id "(null)" twice for "device"
> Well, adding two devices with the same id is bad, and if that id is a NULL 
> pointer anyway IMHO it's better to not pass the parameter at all. That's what 
> the "null-pci-id" patch does.

The goal of libvirt when using QEMU >= 0.12 is that 'id=' parameter is set
for all devices. This enables libvirt reliably identify devices when talking
to QEMU. Since you were seeing '(null)' there must be a place in the code
where we've forgotton to generate the device alias name for hotplug. We should
fix that, rather than hiding the problem.

> -next, detaching failed. I found out that the command sent to qemu was " 
> pci_del pci_addr=fc67add0:7f41:fe38b65a" which is obviously bogus. After some 
> hours of digging through the command stack up and down I found that it was the 
> memcpy addressed in the "pci_memcpy" patch.
> When the device is attached qemu just replies with an empty string. Afterwards 
> from the guestAddr the address of the PCI device in the client is copied back 
> to the info structure. Too bad that this structure was never initialized to 
> anything useful (at least not for me). When I kick out the memcpy() everything 
> works fine.

Ok, I see what's wrong here. The code has two ways of attaching devices

    if (qemuCmdFlags & QEMUD_CMD_FLAG_DEVICE)
        ret = qemuMonitorAddDevice(priv->mon, devstr);
        ret = qemuMonitorAddPCIHostDevice(priv->mon,

With the qemuMonitorAddDevice() method, libvirt decides the PCi address ahead
of time. In the qemuMonitorAddPCIHostDevice() method, QEMU decides the PCI
addresses & tells us about it. Thus we only want todo the memcpy() bit in the
'else' case, never the 'if' case. 

> Note: when the client PCI id is passed to qemu anyway it would be cool if that 
> could be specified in the device XML. For USB devices, too.

You already can supply the PCI address in the XML - if you run 'virsh dumpxml'
on your running guest you'll see the syntax for PCI addresses. For USB devices,
the device IDs on the bus are assigned by the guest OS when it activates the
USB devices, so I don't think there's any way to allow user specification of

|: Red Hat, Engineering, London    -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org -o- http://virt-manager.org -o- http://deltacloud.org :|
|: http://autobuild.org        -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-   F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|

More information about the libvir-list mailing list