[libvirt] Segmentation Fault while connecting to ESX VMware

Matthias Bolte matthias.bolte at googlemail.com
Thu Mar 11 17:13:20 UTC 2010

2010/3/11  <blbmdsmith at verizon.net>:
> Has anyone had a similar issue while trying to connect to VMware's ESX
> systems?
> I am running the following command: libvirt.openAuth("esx://IPADDRESS/ ",
> 1,0)
> From what I have read about connecting to an ESX system, libvirt.openAuth
> calls virConnectOpenAuth which needs three arguments: uri, auth, flags
> I am not sure what values I should use for auth and flags.

"esx://IPADDRESS/ " <- There is a space after the last slash in the
URI, this may or may not be a problem, you should remove it.

The flags paramater can be 0, but auth must be a list with a
predefined set of items. See examples/python/esxlist.py for how to use
the openAuth() function correctly.

> When I run my python script I get a segmentation fault.  I have tried to run
> the same script on Fedora11 and CentOS 5.4.
> I get the same result on both systems.  I have googled this issue, which
> returned a possible issue with not having libvirt-bin installed.
> The libvirt on both systems are from the original installation of the OS for
> each system.

You see a segfault because Python bindings for the virConnectOpenAuth
function are missing proper type checking for parameters. I'll fix

If you use the openAuth() function with the correct parameters you
won't get a segfault.


More information about the libvir-list mailing list