[libvirt] Unable to open virt-manager

Cole Robinson crobinso at redhat.com
Wed Mar 24 13:49:33 UTC 2010

On 03/24/2010 03:06 AM, Doron Fediuck wrote:
> On Tuesday 23 March 2010 21:53:04 Cole Robinson wrote:
>> On 03/23/2010 12:12 PM, Doron Fediuck wrote:
>>> Hi,
>>> I'm trying to work remotely on a server with F12, using vnc.
>>> When I start virt-manager, I do not get the authentication popup, and instead I get this message:
>>> Unable to open connection to hypervisor URI 'qemu:///system':
>>> authentication failed
>>> Traceback (most recent call last):
>>>   File "/usr/share/virt-manager/virtManager/connection.py", line 872, in _try_open
>>>     None], flags)
>>>   File "/usr/lib64/python2.6/site-packages/libvirt.py", line 102, in openAuth
>>>     if ret is None:raise libvirtError('virConnectOpenAuth() failed')
>>> libvirtError: authentication failed
>> Are you running virt-manager over VNC? There were problems like this in
>> the past, since VNC isn't a full desktop session, PolicyKit doesn't run.
>> Other then that, not sure what could be wrong.
>> - Cole
> I wasn't aware of problems in VNC.
> So is there a work around ? How can I work remotely, if VM networking is local (ie- NAT) ?

The VNC issue is only if you are connecting to your remote machine using
VNC, not if the VMs are using VNC. The alternatives are to run
virt-manager as root on the remote machine, use ssh -X instead of VNC,
or possibly alter PolicyKit rules to auto allow connecting for that user
(though I haven't tried it, and it may still fail).

- Cole

More information about the libvir-list mailing list