[libvirt] Two issues regarding TFTP support in virtual networks...

Paolo Bonzini pbonzini at redhat.com
Wed Mar 24 14:34:04 UTC 2010

On 03/24/2010 01:08 PM, Darryl L. Pierce wrote:
> On Thu, Mar 11, 2010 at 04:10:24PM -0500, Darryl L. Pierce wrote:
>>> Here is what's output by libvirtd:
>>> 11:36:57.608: debug : virRun:809 : /usr/sbin/dnsmasq --strict-order --bind-interfaces --pid-file=/var/run/libvirt/network/testbr6762.pid --conf-file=  --listen-address --except-interface lo --dhcp-range, --dhcp-lease-max=100 --enable-tftp --tftp-root /tmp/tmp.HRG19a7Udi --dhcp-boot tftpboot/pxelinux.0
>>> Now, this command line matches, WRT the pxe booting elements, our
>>> pre-0.7 libvirtd test script that worked just fine. And I do see in the
>>> vm getting an address via dhcp. But i'm still getting the error
>>> "No filename or root path specified."
>>>> Also, have you tried using wireshark to see what's going on?
>>> No, I haven't.
>> Following up on this: I'm still unable to get the tftp element for this
>> to work with our autotesting script.
> I'm still in the same state here. Shall I open a bug against libvirt
> regarding it not recognizing the --tftp-root argument?

That would be against dnsmasq?


More information about the libvir-list mailing list