[libvirt] [libvirt-glib] Correct namespace prefix for GVirConfig symbols
cfergeau at redhat.com
Thu Dec 22 17:55:53 UTC 2011
On Thu, Dec 22, 2011 at 07:33:22PM +0200, Zeeshan Ali (Khattak) wrote:
> The patch improves the situation as it makes the whole API very
> consistent w.r.t what exactly is the namespace here.
Imo the namespace really is GVir::Config, not a GVirConfig namespace
totally separate from the GVir namespace, so it does not make the whole API
"very consistent", it just changes things.
> I also
> agree that nested namespaces will be better. If we decide/manage to go
> towards nested namespaces, this patch actually helps in that regard as
> well since existing API is not consistent/correct for that purpose
It helps *but breaks every library user*. Which is why you have to
carefully weight the pros and cons. It makes things slightly nicer,
slightly more consistent but *it breaks every user*. This is what makes it
special and worth more considerations than a quick ack while everyone is on
> > I'm fine if it goes in too. Let's see what danpb thinks
> > about it :)
> I think his intention is pretty clear from the bindings but I can wait.
Yeah, under the assumption that what is in the bindings is right...
Really, let's just wait until the holidays are over, as far as I'm
concerned I wouldn't like having such a patch go in before I get a chance
to see it even if I agree with it.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 198 bytes
Desc: not available
More information about the libvir-list