[libvirt] FreeBSD Port, update to 0.9.2 compile error

Jason Helfman jhelfman at e-e.com
Fri Jul 1 22:30:58 UTC 2011

On Fri, Jul 01, 2011 at 04:21:54PM -0600, Eric Blake thus spake:
>On 07/01/2011 03:15 PM, Jason Helfman wrote:
>> On Fri, Jul 01, 2011 at 03:07:06PM -0600, Eric Blake thus spake:
>>> On 07/01/2011 02:58 PM, Jason Helfman wrote:
>>>> I applied this patch (cleanly), and it still breaks:
>>>> gmake[3]: Leaving directory
>>>> `/home/jhelfman/ports/devel/libvirt/work/libvirt-0.9.3/tools'
>>>> gmake[2]: Leaving directory
>>>> `/home/jhelfman/ports/devel/libvirt/work/libvirt-0.9.3/tools'
>>>> Making all in docs
>>>> gmake[2]: Entering directory
>>>> `/home/jhelfman/ports/devel/libvirt/work/libvirt-0.9.3/docs'
>>>>   GEN    libvirt-api.xml
>>>>   ./apibuild.py: not found
>>> Can you please run 'make V=1 SHELL="sh -vx"' so we can get a better
>>> picture of what make tried to do here?
>> Done. Here is the log of the run:
>> http://jgh.devio.us/files/libvirt.log.gz
>Thanks (I was only interested in the tail of that, so you were wise to
>post the file to a website rather than spamming the list with the entire
>gmake[2]: Entering directory
>srcdir=. ./apibuild.py
>+ srcdir=. ./apibuild.py
>./apibuild.py: not found
>gmake[2]: *** [libvirt-api.xml] Error 127
>This looks like your Makefile was not regenerated after your Makefile.am
>change; there's no evidence that make expanded $(PYTHON) anywhere.  Did
>you just patch the release-candidate tarball, or are you working from
>libvirt.git?  I still think the latest libvirt.git has fixed things, so
>if you are just working from tarballs, either we will have an RC3 for
>you to test, or you'll have to figure out how to regenerate things yourself.
>Do you have automake and autoconf installed?  If so, 'autoreconf -v'
>before your next make should fix things.
>Eric Blake   eblake at redhat.com    +1-801-349-2682
>Libvirt virtualization library http://libvirt.org

Ok, this worked. I was using the downloaded rc3 tarball, and I added the
patches in the build process, as FreeBSD ports patch prior to the build. I
added in to use autotools and ran a clean build, and it worked with no

USE_AUTOTOOLS=	automake autoconf


Jason Helfman
System Administrator
E4AD 7CF1 1396 27F6 79DD  4342 5E92 AD66 8C8C FBA5

More information about the libvir-list mailing list