[libvirt] Problems with "attach-interface" command of libvirt

Tao Siheng taomeix at 126.com
Thu Sep 1 06:35:49 UTC 2011

Dear libvirt-developer:
    I'm a student of computer science and technology in China. I encountered a problem when I want to attach a bridge to an existed Virtual Machine.
    I used the command "attach-interface domain_id bridge br0 --target tap0". "br0" was created by brctl and "tap0"  was created by tunctl.Here is the error information:
 error: Failed to attach interface
error: internal error unable to send TAP file handle: No file descriptor supplied via SCM_RIGHTS.

    I know there are some bugs in the earlier version of libvirt. So I upgraded the ubuntu kernel to and added the module "macvtap" by the using the command "sudo modprobe macvtap". I have installed libvirt0.8.8, QEMU 0.8.8 and  QEMU 0.12.3.Although I did all the above, the problem is still not solved.
    I need your help sincerely.
                                                                                                                                                                Tao Siheng
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/libvir-list/attachments/20110901/c339d2e0/attachment-0001.htm>

More information about the libvir-list mailing list