[libvirt] bug: try to take disk snapshot for LVM2 Volume

MATSUDA, Daiki matsudadik at intellilink.co.jp
Fri Sep 30 05:26:17 UTC 2011

I tried the new snapshot function implemented by Eric Blake.

It works very well for QCOW2 disk image system.
But I often use LVM2 volume for QEMU virtual machines and tried to take
disk snapshot by virsh command ( snapshot-create DOMNAME --disk-only).
So, finally qemu monitor command 'snapshot_blkdev' accepts the LVM2
volume and create QCOW2 snapshot image. In addition, domain's
configuration file is replaced to use snapshot disk image instead of
LVM2 volume.

configuration file
<disk type='block' device='disk>
  <driver name='qemu' type='raw' cache='none'/>
  <source dev='dev/VG1/LVM2_dom'/>

<disk type='block' device='disk>
  <driver name='qemu' type='qcow2' cache='none'/>
  <source dev='dev/VG1/LVM2_dom.1317357844'/>

After then, the domain runs well till it is shutdowned. I started the
domain, but it does not with following error
virtsh # start LVM2_dom
error: Failed to start domain LVM2_dom
error: 内部エラー Process exited while reading console log output: char
device redirected to /dev/pts/7
qemu: could not open disk image /dev/VG1/LVM2_dom.1317357844: Invalid

I think that if the volume but qcow2 is given libvirt should be refuse,
e.g. in qemuDomainSnapshotCreateDiskActive() with voulme driver type.
But currently the structures concerning with snapshot or disk has no
member to hold such a volume driver information. In addition, as we want
to add the LVM2 and other volume snapshot function, we hope you add its
information and fix.


More information about the libvir-list mailing list