[libvirt] Unable to compile libvirt git src... python-config error

Deepak C Shetty deepakcs at linux.vnet.ibm.com
Wed Feb 1 14:38:13 UTC 2012


On 02/01/2012 07:56 PM, Jiri Denemark wrote:
> On Wed, Feb 01, 2012 at 19:49:43 +0530, Deepak C Shetty wrote:
>> Hi All,
>>       I am getting this error, while trying to compile latest git src.
>>
>> ./autogen.sh --prefix=$HOME/usr --enable-compile-warnings=error
>> running bootstrap...
>> ./bootstrap: Error: 'python-config' not found
>>
>> ./bootstrap: Please install the prerequisite programs
>> Failed to bootstrap, please investigate.
>>
>> I am ubuntu, and all packages related to python-config are installed..
>> as seen by the 'i' below...
>>
>> aptitude search python-config
>> i
>> python-configglue
>> - Glues together optparse.OptionParser and ConfigParser.ConfigParser
>> i
>> python-configobj
>> - simple but powerful config file reader and writer for Python
>>
>> Can someone help, what i am missing ?
> Those are unrelated. The python-config we need is what python-dev (or
> similarly called package) should provide.
>
> Jirka
>
>
thanks, that worked... the error is indeed misleading.




More information about the libvir-list mailing list