[libvirt] [PATCH] virsh: add aliases 'boot', 'stop', and 'restart'

James B. Byrne byrnejb at harte-lyne.ca
Thu Nov 8 15:30:55 UTC 2012

On Thu, November 8, 2012 09:24, Daniel P. Berrange wrote:

> NACK to this patch. I think the current command names are good.
> Creating duplicates will make life worse. First, it creates
> divergance from the similarly named commands for networks,
> storage and other objects. It also means scripts written again
> the new commands will not work with existing libvirt.

Duplicates (aliases) will make life worse for whom?  In what way?  On
what evidence?  The present nomenclature is idiomatic to virsh and is
a variance with how many people think of managing a host whether
virtual or not.  On the other hand, one does not customarily speak of
rebooting a network or a storage array, at least not in my experience.

> I actually think that shutdown & reboot are *better* names
> than restart and stop.

Then change start to boot and be done with it.  But, the issue really
is what English words are commonly associated with each other in the
context we are dealing with.  I submit that 'start' is not intuitively
associated with 'shutdown' by the vast majority of English speakers
and hardly associated with 'reboot' by any.

Consider the syntax of 'initctl' and 'service'.  Initctl uses start,
stop and restart.  Service scripts virtually without exception use
start, stop and restart, including that for libvirtd.  Operators are
far more likely to be familiar with this combination of terms than any
other.  Why force them to learn yet one more variant?  What is the
advantage for the users?

***          E-Mail is NOT a SECURE channel          ***
James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3

More information about the libvir-list mailing list