[libvirt] [PATCH 1/7] Rename 'clone' to 'cloneFrom' to avoid name clash with clone() syscall

Peter Krempa pkrempa at redhat.com
Thu Mar 7 17:14:45 UTC 2013


On 03/07/13 17:41, Daniel P. Berrange wrote:
> From: "Daniel P. Berrange" <berrange at redhat.com>
>
> On RHEL-4 vintage one of the header files is polluted causing a
> clash between the clone() syscall and the 'clone' parameter in
> a libvirt driver API
>
> Signed-off-by: Daniel P. Berrange <berrange at redhat.com>
> ---
>   src/driver.h | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/src/driver.h b/src/driver.h
> index f60bf93..0931be2 100644
> --- a/src/driver.h
> +++ b/src/driver.h
> @@ -1443,7 +1443,7 @@ typedef char *
>   typedef virStorageVolPtr
>       (*virDrvStorageVolCreateXMLFrom)         (virStoragePoolPtr pool,
>                                                 const char *xmldesc,
> -                                              virStorageVolPtr clone,
> +                                              virStorageVolPtr clonefrom,

libvirt.c uses "clonevol" here.

>                                                 unsigned int flags);
>   typedef int
>       (*virDrvStorageVolDownload) (virStorageVolPtr vol,
>

ACK the name in the header isn't that important.

Peter




More information about the libvir-list mailing list