[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Error



You're missing the linux kernel headers package. Try installing with:

$ sudo apt-get install linux-headers-`uname -r`

Is there a reason you need to compile your own verse using the provided package from the system?

e.g., 

$ sudo apt-get install libvirt0


On Wed, Aug 6, 2014 at 9:53 PM, ahmad jan <mr_ahmadjan yahoo com> wrote:
I am using Libvirt-1.0.0 on ubuntu 14.02 LTS and found the following error

"checking linux/if_bridge.h usability... no
checking linux/if_bridge.h presence... yes
configure: WARNING: linux/if_bridge.h: present but cannot be compiled
configure: WARNING: linux/if_bridge.h:     check for missing prerequisite
headers?
configure: WARNING: linux/if_bridge.h: see the Autoconf documentation
configure: WARNING: linux/if_bridge.h:     section "Present But Cannot Be
Compiled"
configure: WARNING: linux/if_bridge.h: proceeding with the compiler's result
configure: WARNING:     ## ------------------------------------- ##
configure: WARNING:     ## Report this to libvir-list <at> redhat.com ##
configure: WARNING:     ## ------------------------------------- ##
checking for linux/if_bridge.h... no
configure: error: You must install kernel-headers in order to compile
libvirt with QEMU or LXC support"

Please Guide, how do I recover it

thanks
 

--
libvir-list mailing list
libvir-list redhat com
https://www.redhat.com/mailman/listinfo/libvir-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]