[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Error



On 08/06/2014 08:53 PM, ahmad jan wrote:
> I am using Libvirt-1.0.0 on ubuntu 14.02 LTS and found the following error
> 
> "checking linux/if_bridge.h usability... no
> checking linux/if_bridge.h presence... yes
> configure: WARNING: linux/if_bridge.h: present but cannot be compiled

if_bridge.h has had a hairy history.  The kernel developers have done a
lousy job, and we have had to patch our configure.ac no less than three
times to work around their changes.

Make sure you have at least commits c308a9a and 1bf661c (both from
1.0.2) backported to your build environment.

But if you are going to self-build, why not just build 1.2.7?  Libvirt
remains backward-compatible, so the newer build should work just fine in
place of the older 1.0.0.

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]