[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH V5 01/12] src/xenxs: Export code for reuse



On 08/11/2014 11:20 PM, Jim Fehlig wrote:
> Kiarie Kahurani wrote:
>> wrap code tagged for resuse into one function and export it
>>
>> Signed-off-by: Kiarie Kahurani <davidkiarie4 gmail com>
>> ---
>>  src/xenxs/xen_xm.c | 73 +++++++++++++++++++++++++++++++-----------------------
>>  src/xenxs/xen_xm.h |  2 ++
>>   
> 
> This patch got me thinking about the 'xenxs' directory and its
> contents.  IMO, the directory should be named 'xenconfig' since it
> contains parsing/formating functions for the various xen config
> formats.  Its contents should be xen_sxpr.[ch] for sxpr format,
> xen_xm.[ch] for xm format, and xen_xl.[ch] for xl format. 
> xen_common.[ch] would contain parsing/formating functions common to xm
> and xl.  Any opinions on this layout?  I can work on a patch if others
> think this is reasonable.

Sounds fine to me.  And 'git mv' makes it rather easy to do; just make
sure you have 'git config diff.renames true' before sending the patch,
so that the patch is compressed to just the tweaks accounting for the
new names rather than wholesale delete/add actions.

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]