[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] 1.2.0 segfault on Centos 6



On Tue, 04 Feb 2014 10:19:56 -0700
Eric Blake <eblake redhat com> wrote:

> On 02/04/2014 09:02 AM, Franky Van Liedekerke wrote:
> > Hi,
> > 
> > using libvirt 1.2.0 on a up-to-date Centos6.5 machine leads to
> > occasional segmentation faults (see below).
> > Sometimes it runs for 5 minutes, sometimes for an hour, but after
> > that the result is always the same: segfault after some weird
> > qom-list, that apparently the qemu version on centos doesn't know.
> > Has 1.2.1 a known fix for this?
> > 
> > Franky (debug log of last crash is below the dotted line)
> > 
> > -------------------------------------------------
> > 
> > 2014-02-04 15:50:27.351+0000: 9082: error :
> > qemuMonitorJSONCheckError:354 : internal error: unable to execute
> > QEMU command 'qom-list': The command qom-list has not been found
> > Caught Segmentation violation dumping internal log buffer:
> > 
> 
> Sounds to me like poor fallback - a patch in libvirt was tested
> against a newer version of qemu that provides qom-list, but doesn't
> gracefully handle older qemu where it doesn't work.
> 
> Are you in a position to bisect which libvirt patch introduced the
> problem?  It looks like our first use of qom-list was in 1.1.1, with
> commit d76a897.

Errr ... I don't really know what you mean with bisect ... but tell me
what to do, and I'll try my best tomorrow.

Franky


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]