[libvirt] missing libvirt-sock after compile and install libvirt 1.2.6

Claudio Bley cbley at av-test.de
Wed Jul 30 16:40:29 UTC 2014

At Wed, 30 Jul 2014 09:30:45 -0600,
Eric Blake wrote:
> On 07/30/2014 08:55 AM, Yuanzhen Gu wrote:
> > Hi folks,
> > 
> > I compiled and installed libvirt latest version 1.2.6, based on this
> > tutorial,
> > 
> > http://blog.scottlowe.org/2012/11/05/compiling-libvirt-1-0-0-on-ubuntu-12-04-and-12-10/
> > 
> > I have compiled qemu and installed too, and make a symbolic link to
> > /usr/bin/qemu-system-x86_64
> > 
> > but my question is even I launch a vm in qemu, $virsh list showed nothing,
> > further more,
> > 
> > 1) if I use virtual machine manager, it get connection failiure, due to
> > socket to '/var/run/libvirt/libvirt-sock'; No such file of dirctory.
> That's not the actual error message (because the actual message wouldn't
> mis-spell directory), but is generally the message you see when libvirtd
> is not running.  Are you sure you got your self-built libvirtd installed
> and running correctly?
> > 
> > 2). there is missing libvirt-bin under /etc/init.d/,  after compile and
> > installed libvirt 1.2.6
> I'm not familiar enough with libvirt on ubuntu to know if this is a
> problem.  If you are going to replace your distro's old libvirt with a
> newer self-built version, it is STILL helpful to install your distro's
> libvirt first, to make sure that all the distro-specific tweaks (such as
> setting up /etc/init.d/ and so forth to run libvirtd as a daemon) are in
> place.

Usually, Ubuntu uses upstart. So, there should be a
/etc/init/libvirt-bin.conf which defines the libvirt daemon upstart

I'm not sure whether the configure script detects upstart and installs
the upstart files automatically, though.
> > 3). I tried to start libvirtd daemon, sudo  /usr/sbin/libvirtd/start
> > shows    "/usr/sbin/libvirtd: unexpected, non-option, command line
> > arguments"

I guess that you tried to run "sudo /usr/sbin/libvirtd start"?! This
won't work as "/start" is not a valid non-option command line argument
as the error message already told you.

> According to the tutorial blog that you linked to, it seems like you
> would use 'sudo initctl start libvirt-bin' and not 'sudo
> /usr/sbin/libvirtd/start' to start libvirtd

"sudo start libvirt-bin" is a shortcut method which does the same, BTW.


More information about the libvir-list mailing list