[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] vbox: remove unused code that causes build failures



Sorry for troubling. I'm checking the release note and just find I missed this.
This state existed because it is in the middle of something (say I am rewriting the whole network driver and storage driver for vbox.)
And I did forget to remove vbox[0-9][0-9]NetworkDriver since we don't need it any more. So this patch just fixed it up.
What's more, the whole vboxGetDrivers is removed after rewriting the storage driver.
Taowei

2014-10-04 2:57 GMT+08:00 Martin Kletzander <mkletzan redhat com>:
On Fri, Oct 03, 2014 at 08:50:47PM +0200, Martin Kletzander wrote:
Since 87dea4fcffb2d1b120e7841adc0e3d8ea97ed777 vboxGetDrivers() is not
used for getting the vbox network driver.  The only call the code does
is using NULL as the @networkDriver_ret param , but the code still used
vbox[0-9][0-9]NetworkDriver that didn't exist anymore.

Signed-off-by: Martin Kletzander <mkletzan redhat com>
---

I didn't do 'format-patch' and 'send-email' doesn't add notes.  So I'm
attaching them now:

I'm not pushing this as a build-breaker because I sense there might be
more to this.  The thing is that it doesn't fail for anyone else I
talked to, neither does it fail for out test suite.

I don't quite understand how it could worked (ever), since the only
definition of vbox22NetworkDriver (and others) was extern throughout
the whole git history.  I'm running autogen using --with-vbox even
though I don't have any virtualbox libraries/binaries installed, but
there is no such requirement for compiling the code.  And I don't
think the libraries would export a virNetworkDriver data struct
either.

Anyway, feel free to let me know where the real problem is and I'll be
glad to help with that either.

--
libvir-list mailing list
libvir-list redhat com
https://www.redhat.com/mailman/listinfo/libvir-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]