[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] DHCP and secure containers



OK, hopefully this mailing list is more active and I can get some response to my questions.
---------------------------------------------------------------------------------------------------------------------
I have been "playing with" Secure Containers running a lighttpd server and have it up and running. I used Adam's process (https://www.happyassassin.net/2014/07/23/bridged-networking-for-libvirt-with-networkmanager-2014-fedora-21/) for getting a bridge defined when also running NetworkManager. I then created a virtual network definition:
<network>
  <name>net18</name>
  <uuid>8d19a05b-ac85-4e2a-88bc-5ca4cbb29a33</uuid>
  <forward mode='bridge'/>
  <bridge name='br0'/>
</network>
This works fine when I use static addresses such as:
-N source=net18,address=192.168.18.94/24,route=192.168.18.255%192.168.18.1
but does not work when I specify using dhcp:
-N source=net18,dhcp
I have reported this as a bug: https://bugzilla.redhat.com/show_bug.cgi?id=1133686

Since there has not been much of a reaction to the BZ report, I decided to take a look at the source code (it sure would have been nice if the SRPMS were there in the F20 fedora-virt-preview but I get the package from development/21).

I see that libvirt-sandbox-init-common.c has the code for starting dhcp and also has main() along with some runtime options for -v verbose and -d debug.

OK, how do I go about turning verbose and/or debug on?

Any suggestions on how to debug and get dhcp to work? I not only want to find the problem but to fix the problem if needed.

Gene


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]