[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 1/3] schemas: finish virTristate{Bool, Switch} transition



On Thu, Sep 11, 2014 at 09:54:51AM -0400, Laine Stump wrote:
On 09/08/2014 07:40 AM, Martin Kletzander wrote:
Signed-off-by: Martin Kletzander <mkletzan redhat com>
---
 docs/schemas/basictypes.rng   |  19 ++++--
 docs/schemas/capability.rng   |  10 +--
 docs/schemas/domaincaps.rng   |   5 +-
 docs/schemas/domaincommon.rng | 155 +++++++++---------------------------------
 docs/schemas/interface.rng    |  19 +-----
 docs/schemas/network.rng      |  29 ++------
 docs/schemas/nwfilter.rng     |   5 +-
 docs/schemas/secret.rng       |  10 +--
 8 files changed, 61 insertions(+), 191 deletions(-)

diff --git a/docs/schemas/basictypes.rng b/docs/schemas/basictypes.rng
index 75d5238..d26da57 100644
--- a/docs/schemas/basictypes.rng
+++ b/docs/schemas/basictypes.rng
@@ -77,10 +77,7 @@
     </attribute>
     <optional>
       <attribute name="multifunction">
-        <choice>
-          <value>on</value>
-          <value>off</value>
-        </choice>
+        <ref name="virSwitch"/>

Purely cosmetic, but how about calling them "virYesNo" and "virOnOff" to
avoid confusion? When I see "virBool" I think "true/false", and when I
see "virSwitch" I think "Does this have something to do with a network
device?" :-)


That's another way (and makes more sense).  I just wanted to shorten
the "Tristate" since it's not a tristate anyway.  Should I count it as
an ACK for s/virSwitch/virOnOff/ and s/virBool/virYesNo/ ?

Martin

Attachment: signature.asc
Description: Digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]