[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 1/3] schemas: finish virTristate{Bool, Switch} transition

On 09/15/2014 01:46 AM, Martin Kletzander wrote:
> On Thu, Sep 11, 2014 at 09:54:51AM -0400, Laine Stump wrote:
>> On 09/08/2014 07:40 AM, Martin Kletzander wrote:
>>> Signed-off-by: Martin Kletzander <mkletzan redhat com>
>>> ---

>>> +        <ref name="virSwitch"/>
>> Purely cosmetic, but how about calling them "virYesNo" and "virOnOff" to
>> avoid confusion? When I see "virBool" I think "true/false", and when I
>> see "virSwitch" I think "Does this have something to do with a network
>> device?" :-)
> That's another way (and makes more sense).  I just wanted to shorten
> the "Tristate" since it's not a tristate anyway.  Should I count it as
> an ACK for s/virSwitch/virOnOff/ and s/virBool/virYesNo/ ?

Yes, I'll agree to that rename.

Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]