[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 3/6] util: storage: Allow metadata crawler to report useful errors




On 09/11/2014 01:47 PM, Peter Krempa wrote:
> Add a new parameter to virStorageFileGetMetadata that will break the
> backing chain detection process and report useful error message rather
> than having to use virStorageFileChainGetBroken.
> 
> This patch just introduces the option, usage will be provided
> separately.
> ---
>  src/qemu/qemu_domain.c        |  3 ++-
>  src/security/virt-aa-helper.c |  2 +-
>  src/storage/storage_driver.c  | 22 +++++++++++++++-------
>  src/storage/storage_driver.h  |  3 ++-
>  tests/virstoragetest.c        |  2 +-
>  5 files changed, 21 insertions(+), 11 deletions(-)
> 

So perhaps this is bikeshedding, but I think rather than 'fail' as a
variable name something like 'force_fail' or 'fail_first_error' :-)...

Just something that will signify what it's doing (and is more easily
searched in cscope than 'fail' :-)).

ACK

John


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]