[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 4/5] conf: add options for disabling segment offloading



On Mon, Sep 15, 2014 at 04:30:46PM -0600, Eric Blake wrote:
> On 09/11/2014 05:43 AM, Ján Tomko wrote:
> > Add the following attributes:
> > csum, gso, guest_tso4, guest_tso6, guest_ecn
> > to the <driver> element of network interface
> > which control the virtio-net device properties
> > of the same names.
> > ---
> >  docs/formatdomain.html.in                          | 27 ++++++++
> >  docs/schemas/domaincommon.rng                      | 25 +++++++
> >  src/conf/domain_conf.c                             | 81 ++++++++++++++++++++++
> >  src/conf/domain_conf.h                             |  5 ++
> >  .../qemuxml2argv-net-virtio-disable-offloads.xml   | 32 +++++++++
> >  tests/qemuxml2xmltest.c                            |  1 +
> >  6 files changed, 171 insertions(+)
> >  create mode 100644 tests/qemuxml2argvdata/qemuxml2argv-net-virtio-disable-offloads.xml
> > 
> > diff --git a/docs/formatdomain.html.in b/docs/formatdomain.html.in
> > index a2ea758..5b2758a 100644
> > --- a/docs/formatdomain.html.in
> > +++ b/docs/formatdomain.html.in
> > @@ -3847,6 +3847,12 @@ qemu-kvm -net nic,model=? /dev/null
> >        &lt;model type='virtio'/&gt;
> >        <b>&lt;driver name='vhost' txmode='iothread' ioeventfd='on' event_idx='off' queues='5'/&gt;</b>
> >      &lt;/interface&gt;
> > +    &lt;interface type='network'&gt;
> > +      &lt;source network='default'/&gt;
> > +      &lt;target dev='vnet2'/&gt;
> > +      &lt;model type='virtio'/&gt;
> > +      <b>&lt;driver csum='off' gso='off' guest_tso4='off' guest_tso6='off' guest_ecn='off'/&gt;</b>
> > +    &lt;/interface&gt;
> 
> Are we stuck with names with underscores in our XML?  I'm still not sure
> if we've come up with the best naming for exposing all these knobs.

I'm not really convinced having a 'guest_' prefix really buys
us anything here, since there's no naming clash to avoid. Why
don't we just kill the 'guest_' prefixes.

NB, remember that precisely matching QEMU naming is a non-goal,
we should be designing something that makes sense in general.

Regards,
Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]