[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Rename tunable event constants



On 09/25/2014 10:51 AM, Daniel P. Berrange wrote:
> For the new VIR_DOMAIN_EVENT_ID_TUNABLE event we have a bunch of
> constants added
> 
>    VIR_DOMAIN_EVENT_CPUTUNE_<blah>
>    VIR_DOMAIN_EVENT_BLKDEVTUNE_<blah>
> 
> This naming convention is bad for two reasons
> 
>   - There is no common prefix unique for the events to both
>     relate them, and distinguish them from other event
>     constants
> 
>   - The values associated with the constants were chosen
>     to match the names used with virConnectGetAllDomainStats
>     so having EVENT in the constant name is not applicable in
>     that respect
> 
> This patch proposes renaming the constants to
> 
>     VIR_DOMAIN_TUNABLE_CPU_<blah>
>     VIR_DOMAIN_TUNABLE_BLKDEV_<blah>
> 
> ie, given them a common VIR_DOMAIN_TUNABLE prefix.

Seems reasonable, and must get into 1.2.9 before we bake the bad naming
into a release.

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]