[libvirt] [PATCH] lxc: Bind mount container TTYs

Richard Weinberger richard at nod.at
Wed Jul 1 10:22:20 UTC 2015

Am 01.07.2015 um 11:40 schrieb Martin Kletzander:
> On Tue, Jun 30, 2015 at 07:54:25PM +0200, Richard Weinberger wrote:
>> Am 30.06.2015 um 19:12 schrieb Martin Kletzander:
>>>> Hmm, very strange. What guest container are you using?
>>>> I tried with a Debian jessi and had user namespace enabled.
>>> Sorry for the late reply.  I used simple one.  Only gentoo's stage 3
>>> unpacked into a directory, no special settings used for it.  Removing
>>> /etc/securetty works for me.  I'll give it another try, but probably
>>> after the freeze.  If anyone else wants to review this, don't get
>>> stopped by the problems I'm having!
>> Hmm, just gave gentoo a try, worked perfectly fine.
> I tried with latest master with and without your patch.  Wtih your
> patch I got to the problem exactly once even though I tried multiple
> times.  And even though it didn't happen to me at all without your
> patch, I'm thinking it's just some weird rare race and it's not
> related to what you've sent.  That just wouldn't make sense to me.
> I also suspected the problem being me starting with --console
> parameter, but trying with and without that didn't help isolate the
> problem either.

--console works fine here.

> Anyway, that patch still doesn't help me get rid of /etc/securetty.
> The output of 'tty' is still /dev/pts/0 and unless I remove
> /etc/securetty it doesn't start.  What is the output of 'tty' and what
> ttys do you have in /etc/securetty in your container?

tty prints as expected /dev/tty1. (instead of /dev/pts/xy)
/etc/securetty is from gentoo, I did not add anything.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://listman.redhat.com/archives/libvir-list/attachments/20150701/85e79a04/attachment-0001.sig>

More information about the libvir-list mailing list