[libvirt] Entering freeze for libvirt-1.2.17

Peter Kieser peter at kieser.ca
Thu Jul 9 21:00:10 UTC 2015

On 2015-06-30 2:49 AM, Daniel Veillard wrote:
> On Tue, Jun 30, 2015 at 11:00:24AM +0200, Guido Günther wrote:
>> On Tue, Jun 30, 2015 at 03:00:09PM +0800, Daniel Veillard wrote:
>>> On Mon, Jun 29, 2015 at 10:34:55PM +0200, Guido Günther wrote:
>>>> On Sun, Jun 28, 2015 at 01:00:01PM +0800, Daniel Veillard wrote:
>>>>>    Following discussions on Friday, I applied the patches to deactivate
>>>>> the subset of Admin APIs and revert from 1.3.0 to 1.2.17. I then tagged
>>>>> in git and pushed signed tarballs and rpms to the usual place:
>>>>>    ftp://libvirt.org/pub/libvirt/
>>>>>   I didn't run my usual tests on that one, my infra is in flux,
>>>>> so even more reasons for people to give it a try :-)
>>>>>   I'm likely to make a candidate release 2 on Tuesday and if all goes
>>>>> well we can push 1.2.17 on Thursday,
>>>> Building the tarball fails for me with:
>>>> make[4]: Entering directory '/tmp/buildd/libvirt-1.2.17~rc1/debian/build/docs'
>>>> missing XHTML1 DTD
>>>> cat: internals/locking.html.tmp: No such file or directory
>>>> Makefile:2385: recipe for target 'internals/locking.html' failed
>>>> make[4]: *** [internals/locking.html] Error 1
>>>    The missing XHTML1 DTD just means you can't validate the locking.html.tmp
>>> against a local copy of the DTD for XHTML1, but then it seems that
>>> the locking.html.tmp wasn't generated.
>>> It should be generated via xsltproc, it seems it's missing in
>>> your build environment, make sure you have it.
>>> Make sure you have xmllint, xsltproc and xhtml1-dtds in your build system,
>> I should have added that I tried this with and without xsltproc +
>> xmllint. I now also added the DTDs but no change (the build env didn't
>> change since the last release).
>    humpf ... locking.html.in wasn't touched since Feb, that need more attention
> and building from the tarballs worked here, strange
> Daniel

I had to revert this commit to get 1.2.17 to build under debian 
packaging chroot.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4291 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://listman.redhat.com/archives/libvir-list/attachments/20150709/09ab1242/attachment-0001.p7s>

More information about the libvir-list mailing list