[libvirt] [PATCH 0/7] iothread api followups

Ján Tomko jtomko at redhat.com
Wed Mar 25 18:39:05 UTC 2015


Looking at the proposed SetIOThread API, I noticed
that the virsh command for printing the info is named 'iothreadsinfo'.
This seemed counter-intuitive for me.

Since the API has not been released yet, I propose a rename of the command to:
iothreadinfo (patch 5)
and the API for freeing one struct to:
virDomainIOThreadInfoFree (patch 1)

I don't feel as strongly about renaming the virDomainGetIOThreadsInfo API
(patches 3, 4) or the internal APIs (patch 2).

Looking at virVcpuInfoPtr (which might not be the best inspiration),
I realized including the cpu time might be a good idea.

Ján Tomko (7):
  Rename virDomainIOThreadsInfoFree to virDomainIOThreadInfoFree
  Rename qemuMonitorIOThreadsInfo* to qemuMonitorIOThreadInfo*
  Rename DomainGetIOThreadsInfo to DomainGetIOThreadInfo
  gendispatch: remove IOThreads from name fixups
  virsh: rename iothreadsinfo to iothreadinfo
  Do not use vshPrintPinInfo in iothreadinfo
  add cpu time to iothreadinfo

 daemon/remote.c                  | 15 +++++++------
 include/libvirt/libvirt-domain.h |  5 +++--
 src/driver-hypervisor.h          |  4 ++--
 src/libvirt-domain.c             | 20 ++++++++---------
 src/libvirt_public.syms          |  4 ++--
 src/qemu/qemu_driver.c           | 24 ++++++++++++++------
 src/qemu/qemu_monitor.c          |  4 ++--
 src/qemu/qemu_monitor.h          | 10 ++++-----
 src/qemu/qemu_monitor_json.c     |  8 +++----
 src/qemu/qemu_monitor_json.h     |  2 +-
 src/qemu/qemu_process.c          |  4 ++--
 src/remote/remote_driver.c       | 23 ++++++++++----------
 src/remote/remote_protocol.x     | 11 +++++-----
 src/remote_protocol-structs      |  7 +++---
 src/rpc/gendispatch.pl           |  1 -
 tests/qemumonitorjsontest.c      |  4 ++--
 tools/virsh-domain.c             | 47 ++++++++++++++++++++++++++++------------
 17 files changed, 113 insertions(+), 80 deletions(-)

-- 
2.0.5




More information about the libvir-list mailing list