[libvirt] [PATCH 02/13] qemu: eliminate duplicated code in qemuBuildDriveDevStr()

John Ferlan jferlan at redhat.com
Fri May 8 16:39:23 UTC 2015

On 05/05/2015 02:03 PM, Laine Stump wrote:
> The code to add device type to the commandline was identical for lsi
> and other models of SCSI controllers, but was duplicated (with the
> exception of a minor ordering difference of the if-else clauses) for
> the two cases. This patch replaces those two with a single instance of
> the code just before the if().
> ---
>  src/qemu/qemu_command.c | 39 +++++++++++++--------------------------
>  1 file changed, 13 insertions(+), 26 deletions(-)



More information about the libvir-list mailing list