[libvirt] Issue with Parallel/VZ driver on Parallel Cloud Server 6.0

Maxim Nestratov mnestratov at virtuozzo.com
Tue Nov 10 17:16:42 UTC 2015

10.11.2015 19:32, Frank Laszlo пишет:
> Hello,
> I've been tasked with integrating libvirt into a server running 
> Parallel Cloud Server 6.0. However, it seems I've ran into some 
> trouble getting the vz/parallel driver to compile. It appears there 
> might be an issue with the version of parallels-virtualization-sdk 
> thats installed (6.10.24195)
> I first tried using the latest libvirt version, 1.2.21. After finding 
> the magical configure arguments and ENV variables to get it to find 
> the SDK, the configure script reported "Yes" next to the vz driver. I 
> then proceeded to run a make, and was confronted with the following 
> error message:
> vz/vz_sdk.c: In function 'prlsdkAddNet':
> vz/vz_sdk.c:2964: error: 'PRL_USE_VNET_NAME_FOR_BRIDGE_NAME' 
> undeclared (first use in this function)
> vz/vz_sdk.c:2964: error: (Each undeclared identifier is reported only once
> vz/vz_sdk.c:2964: error: for each function it appears in.)
> make[3]: *** [vz/libvirt_driver_vz_la-vz_sdk.lo] Error 1
> make[3]: Leaving directory `/root/libvirt-1.2.21/src'
> I then tried to use libvirt 1.2.16, thinking that if I go back a few 
> versions to before the driver was renamed (parallels -> vz), it might 
> work. This appears to have sorted out the compiler errors, however, 
> when it goes to link the modules, I get the following:
Hello Frank,

The version of parallels-virtualization-sdk provided with Parallels 
Cloud Server 6.0 is not supposed to be linked with libvirt. You need an 
open version, which comes with the next VZ 7.0. You can get sources from 

Then build it yourself.
If have any questions, please feel free to contact me directly.

Maxim Nestratov

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/libvir-list/attachments/20151110/e8d58106/attachment-0001.htm>

More information about the libvir-list mailing list