[libvirt] gem install ruby-libvirt fails on FreeBSD 10.2

Roman Bogorodskiy bogorodskiy at gmail.com
Tue Oct 20 10:49:35 UTC 2015

  Rickard von Essen wrote:

> Hi,
> Installing the ruby-libvirt gem fails on FreeBSD 10.2 since it can't locate
> the lib and include dir. Installing with:
>   gem install ruby-libvirt --
> --with-libvirt-include=/usr/local/include/libvirt
> --with-libvirt-lib=/usr/local/lib/libvirt.so
> works fine.
> It would be great if this worked out of the box, e.g. detects that it is
> building on BSD and applies the above settings as default, or at least it
> could be provided as a hint if running make fails to guide ruby noobs, like
> me.

Hi Rickard,

I tried it on my system and it seems to work fine without manually
providing include and lib paths.

>From what I can see, it uses pkg-config to detect CFLAGS and LDFLAGS (I
could be wrong here though because I'm not familiar with Ruby).

Could you please check if you have this working:

$ pkg-config --libs --cflags libvirt
-I/usr/local/include -L/usr/local/lib -lvirt

If that does not work, could you please describe how did you do the
libvirt installation on your system?


Roman Bogorodskiy

More information about the libvir-list mailing list