[libvirt] [PATCH] docs: Drop unused rule for internals/%.html.tmp target

Martin Kletzander mkletzan at redhat.com
Tue Sep 8 07:58:12 UTC 2015

On Mon, Sep 07, 2015 at 07:15:26PM +0200, Guido Günther wrote:
>On Mon, Sep 07, 2015 at 03:26:26PM +0200, Martin Kletzander wrote:
>> On Wed, Sep 02, 2015 at 09:27:00AM +0200, Guido Günther wrote:
>> >On Tue, Sep 01, 2015 at 03:27:05PM +0200, Michal Privoznik wrote:
>> >[..snip..]
>> >>Guido, I think the original problem you're seeing is just an ordering
>> >>problem. If you revert you patch, and apply this one:
>> >
>> >This gives the same error.  Feel free to revert my change and I keep
>> >the patch in Debian until we tracked down the root cause and don't
>> >interfere with the 1.2.19 release.
>> >
>> The release was done without the revert, but newer Debian is more
>> important then super-old CentOS.  The problem is that we still have
>> broken subsites (the internal pages).  I tried reproducing your
>> problem on our debian installation and I couldn't.  I have no idea how
>> the versions go, etc.  But I really badly want to fix this.  What are
>> the versions and steps to reproduce for the original problem you were
>> trying to fix?  I'm starting fresh installation to finally fix this
>> once and for all.
>I'm doing a:
>    git revert e5470dd0e0a5be02cbf18a882cfc676b39d1c1a5
>    mkdir build && cd build
>    ../autogen.sh && make -j8  distcheck
>(note the distcheck) and it then fails with:
>make[4]: Entering directory '/var/scratch/src/libvirt/upstream/libvirt/build/libvirt-1.2.20/_build/docs'
>Generating internals/rpc.html.tmp
>Generating internals/locking.html.tmp
>Generating internals/oomtesting.html.tmp
>Generating internals/command.html.tmp
>/bin/bash: line 3: internals/rpc.html.tmp: No such file or directory
>/bin/bash: line 3: internals/locking.html.tmp: No such file or directory
>rm: /bin/bash: line 3: internals/oomtesting.html.tmp: No such file or directory
>rm: cannot remove 'internals/rpc.html.tmp'/bin/bash: line 3: internals/command.html.tmp: No such file or directory
>: No such file or directorycannot remove 'internals/locking.html.tmp': No such file or directory
>Makefile:2366: recipe for target 'internals/locking.html.tmp' failed
>make[4]: *** [internals/locking.html.tmp] Error 1
>make[4]: *** Waiting for unfinished jobs....
>Makefile:2366: recipe for target 'internals/rpc.html.tmp' failed
>make[4]: *** [internals/rpc.html.tmp] Error 1
>rm: cannot remove 'internals/oomtesting.html.tmp': No such file or directory
>rm: cannot remove 'internals/command.html.tmp': No such file or directory
>Makefile:2366: recipe for target 'internals/oomtesting.html.tmp' failed

No message like that for me.  I completes with 2 test failures (namely
qemuxml2argvtest and virsh-uriprecedence), but no problem with any
html files being generated.  And I tried this on both stable and
unstable debian installations.

Would you mind also trying one patch I proposed upstream?  I know it
will seem a bit far-fetched, desperate times call for desperate
measures, I guess.  I'm talking about this one:



> -- Guido
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://listman.redhat.com/archives/libvir-list/attachments/20150908/d6e4fdea/attachment-0001.sig>

More information about the libvir-list mailing list