[libvirt] Drop support for old libvirt versions?

Andrea Bolognani abologna at redhat.com
Fri Aug 12 16:25:16 UTC 2016

A while ago, we agreed to drop support for QEMU versions older
than 0.12.0, with the rationale that we should focus on
operating systems that are still supported by the respective
vendors, eg. RHEL/CentOS 6, Ubuntu 12.04 and SLES 11.

Recently, when discussing how to ensure a certain change will
not break migration with libvirt <= 0.9.4, I started wondering
whether we should apply the same rationale to libvirt versions
as well.

Here's a quick run down of relevant libvirt versions:

  SLES 11        → ???
  RHEL 6.0       → 0.8.1
  Ubuntu 12.04   → 0.9.2

  RHEL 6.8       → 0.10.2
  Ubuntu 12.04.5 → 0.9.8
  SLES 11 SP4    → 1.2.5

One thing I'm not clear about is whether or not SUSE, Red
Hat and Canonical will support old minor releases or just
the latest one. If the latter, we could safely drop support
for anything older than 0.9.8, which incidentally would make
the discussion referenced above entirely moot ;)

In any case, having a well-defined cut-off point has been
very useful when dealing with QEMU, so I think having one
for libvirt itself would be beneficial too.

Looking forward to your thoughts on this :)

Andrea Bolognani / Red Hat / Virtualization

More information about the libvir-list mailing list