[libvirt] [PATCH 06/12] qemu: Move qemuNetworkIfaceConnect to qemu_interface.c and rename

John Ferlan jferlan at redhat.com
Mon Feb 15 23:35:48 UTC 2016

On 02/15/2016 05:38 PM, Laine Stump wrote:
> On 02/15/2016 02:37 PM, John Ferlan wrote:
>> Move the misplaced function from qemu_command.c to qemu_interface.c
>> since it's closer in functionality there and had less to do with building
>> the command line.
>> Rename function to qemuInterfaceNetworkConnect and modify callers.
> This function really is connecting to a bridge (either one that is part
> of a libvirt network, or a host bridge defined outside libvirt), so I
> would suggest qemuInterfaceBridgeConnect(). (I had considered suggesting
> qemuInterfaceTapConnect (and the other one
> qemuInterfaceMacvlanConnect()), but I think I like naming them *Bridge*
> and *Direct* instead).
> ACK with the name change.

OK - done

> (Of course in the end both functions should end up being called by some
> function called qemuInterfaceConnect(), and that function will be the
> only one called from qemu_command.c. No sense in going wild right out of
> the chute though, eh? :-)

Baby steps... It's the new normal.

Although I'll keep this in mind... Could be a challenge due to
qemu_hotplug usage and calling sequence, but we'll see.


More information about the libvir-list mailing list