[libvirt] [PATCH 1/6] conf: move virDomainDeviceInfo definition from domain_conf.h to device_conf.h

Ján Tomko jtomko at redhat.com
Thu May 19 17:20:30 UTC 2016

On Wed, May 18, 2016 at 03:23:49PM -0400, Laine Stump wrote:
> Also moves all the subordinate structs. This is necessary due to a new
> inline function that will be defined in device_conf.h, and also makes
> sense, because it is the *device* info that's in the struct. (Actually
> a lot more stuff from domain_conf.h could move to this newer file, but
> I didn't want to disturb any more than necessary).

This would be easier to read as a pure code motion, with the typedef
style change being separate.


> ---
>  src/conf/device_conf.h | 111 +++++++++++++++++++++++++++++++++++++++++-
>  src/conf/domain_conf.h | 129 -------------------------------------------------
>  2 files changed, 110 insertions(+), 130 deletions(-)

More information about the libvir-list mailing list