[libvirt] [PATCH v2 18/20] network: Rename @filter to @aclfilter

Michal Privoznik mprivozn at redhat.com
Wed Aug 16 07:36:36 UTC 2017

On 08/15/2017 10:56 PM, John Ferlan wrote:
> On 08/15/2017 11:32 AM, Michal Privoznik wrote:
>> On 07/26/2017 05:05 PM, John Ferlan wrote:
>>> Rename the virNetworkObjListFilter to be virNetworkObjListACLFilter
>>> since that's more representative of what it is. Also modify the
>>> variable @filter to be @aclfilter. In the future adding the ability
>>> to describe a generic @filter routine for the Export functions
>>> could be a useful thing.
>> Well technically this is a filter. It's only that we use ACL filter
>> function for it. But the implementation is generic enough for the cb to
>> be called filter IMO. Therefore I'm not a fan of this one.
>> Michal
> Understood - I can drop it, but then it's different than what I've
> already done in nwfilter, secret, nodedevice, and storage.

Darn, did those slip in? Frankly, I'm not a fan of this change.
Therefore I'll no longer object to this change, but probably not ACK it
either. I'd like others to chime in and express their opinion.


More information about the libvir-list mailing list