[libvirt] [PATCH v2 18/20] network: Rename @filter to @aclfilter

John Ferlan jferlan at redhat.com
Wed Aug 16 12:00:36 UTC 2017

On 08/16/2017 04:09 AM, Pavel Hrdina wrote:
> On Wed, Aug 16, 2017 at 09:36:36AM +0200, Michal Privoznik wrote:
>> On 08/15/2017 10:56 PM, John Ferlan wrote:
>>> On 08/15/2017 11:32 AM, Michal Privoznik wrote:
>>>> On 07/26/2017 05:05 PM, John Ferlan wrote:
>>>>> Rename the virNetworkObjListFilter to be virNetworkObjListACLFilter
>>>>> since that's more representative of what it is. Also modify the
>>>>> variable @filter to be @aclfilter. In the future adding the ability
>>>>> to describe a generic @filter routine for the Export functions
>>>>> could be a useful thing.
>>>> Well technically this is a filter. It's only that we use ACL filter
>>>> function for it. But the implementation is generic enough for the cb to
>>>> be called filter IMO. Therefore I'm not a fan of this one.
>>>> Michal
>>> Understood - I can drop it, but then it's different than what I've
>>> already done in nwfilter, secret, nodedevice, and storage.
>> Darn, did those slip in? Frankly, I'm not a fan of this change.
>> Therefore I'll no longer object to this change, but probably not ACK it
>> either. I'd like others to chime in and express their opinion.
> I agree with Michal and I've already pointed this out for the first
> series [1].  In my second response I gave up :) but I still think
> that it should be made as a generic filter.  Since now I'm not the only
> one against this change we should consider "fixing" the other places
> that already use aclfilter.
> Pavel
> [1] <https://www.redhat.com/archives/libvir-list/2017-July/msg00973.html>

<sigh> OK.... To me it just seemed better to admit it was an ACL filter
as opposed to some other kind of filter. As noted that was perhaps a
carryover from my initial efforts where aclfilter and matchfilter were

I will remove this patch from the series and will send a followup to
undo the others once I push.


More information about the libvir-list mailing list