[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH v3 07/12] nodedev: Alter node device obj list function names



On Sat, Jun 03, 2017 at 09:11:57AM -0400, John Ferlan wrote:
> Ensure that any function that walks the node device object list is prefixed
> by virNodeDeviceObjList.
>
> Also, modify the @filter param name for virNodeDeviceObjListExport to
> be @aclfilter.
>
> Signed-off-by: John Ferlan <jferlan redhat com>

One more from the 'not a fan' patches :)...
ACK

Erik

>  static virNodeDeviceObjPtr
> -virNodeDeviceFindByWWNs(virNodeDeviceObjListPtr devs,
> -                        const char *parent_wwnn,
> -                        const char *parent_wwpn)
> +virNodeDeviceObjListFindByWWNs(virNodeDeviceObjListPtr devs,
> +                               const char *parent_wwnn,
> +                               const char *parent_wwpn)

I assume one would argue that calling this function simply *ByWWN wouldn't
reflect the reality and justify the actual need for both wwnn and wwpn.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]